Friday 28th September 2018

dns1.papaki.gr - Unexpected technical issue/ Έκτακτο τεχνικό πρόβλημα

Estimated recovery time:1 Hour

Update: Τhe server function has been fully restored.


Εκτιμώμενος χρόνος αποκατάστασης:1 Ώρα

Update: Η λειτουργία του server έχει αποκατασταθεί.