Monday 23rd April 2018

Shared Hosting linux50.papaki.gr - Unexpected technical issue/ Έκτακτο τεχνικό πρόβλημα

Estimated recovery time: 30 minutes

Update (13:45) : The issue has been resolved.


Εκτιμώμενος χρόνος αποκατάστασης: 30 λεπτά

Update (13:45): Το πρόβλημα έχει αποκατασταθεί πλήρως.